Aprilia RS125 - Mixture Screw And Idle Speed Won't Work

16 posts / 0 new
Last post
Aprilia RS125 - Mixture Screw And Idle Speed Won't Work

ood Afternoon Everybody 

I'm in the process of rebuilding an RS125 and managed to get it started. the problem is that it will just about idle but that's with the idle speed wound all the way in and the mixture screw (Air or Fuel?) has no effect on idling. i have gone through google and the posts on here and checked as much as i can think of. the current settings are 

PHBH 28mm carb (unrestricted bike) 
Main jet - 122 
Pilot jet - 62 (reduced from what i think was 65) 
Emulsion tube - BN266 
Slide - 45 
Needle - x25 

i have spare main jets and throttle tube (50) and some other parts that are the same. i rebuilt this carb as i snapped a screw in my old one so bought a stripped out carb and cleaned it, Cleaned all the jets with carb cleaner and compressed air. transferred all my bits to it with a new seal kit from aprilia, new float needle and set float gap to 24mm. I've changed the pilot jet down as i think it's running rich, (now a standard 62), checked the idle and mixture screws are the correct length and the o-rings are still good. Adjusted the idle with the throttle cable but the carb should just run off the pilot circuit and the idle screw to hold it at idle. i've also checked for leaks with easy start, any ideas? Thanks

Your mixture screw sets the fuel and air balance, have a look on the forums or manufacturers spec charts for the correct setting. Try about 2 1/4 turns out for a start. Or you could ask the service department of a dealer. When you have that set correctly start her on the throttle and see what the idle speed runs at when warm, then adjust it to spec. Info at sportsbikes forum 125 or google Aprilia RS125 set up.

i have tried setting these to every setting under the sun. it runs but is overly rich. normally when adjusting the mixture screw the revs rise or fall depending on which way you turn it. mine does nothing to the rpm, and the idle screw wound all the way in only just scrapes 1200 RPM which indicates a fault to me. i'm on the smallest pilot that aprilia will sell but still the problem remains. what could be the problem that the idle screw doesn't change the idle speed and the mixture screw has no effect on the rpm. Thanks, Ross

Float/needle valve, not regulating fuel supply correctly, check float height set correctly and needle valve seating, A rise in the chamber causes enrichment giving the symptoms you describe. If the needle valve has ever been changed ( I've seen them put in the wrong size before ), and the valve is too small for the seat, fuel gets past causing overrich running, worth a look. A Gunsons colourtune lets you watch the mixture during combustion. Acts a bit like a toilet, when the water flushes the level drops opening the valve (ball drops) as the water comes in, at some level the buoyancy of the float pushes the valve shut.

i thought of the float valve so i changed it for a new needle valve, seat and fibre washer and it still hasn't fixed it. i don't think it is as it's not overflowing when left and i've inspected the float but could it be not sealing because of that, even without a split in it? thankyou for your reply

OK Ross well this has got me thinking now, as if what you say is true you've rebuilt the carb to original specs and settings. So following on logically if its still overrich and carb is ok then combustion process is being starved of oxygen, only explanation, other than timing wrong. Can you double check the timing, and no obstructions in the air induction side such as dirty filter? Beginning to suspect the reed valves are on the way out and not snapping back and sealing properly, they don't last forever. Do you know what they are and where to look?, are they breaking up around edges. I'm not that experienced in two strokes, some of the other guys who read this might be though, any ideas?

it is a mindteaser! i took the reeds out and cleaned them to make sure there was no dirt holding them open etc. they just looked plain black but with sharp defined edges, not fraying or splittling. the timing shouldn't change as its non adjustable. I tested all the screws etc with the airbox on and off and no improvement. any other non carb problems that could cause this? thanks

I can fully understand why you are puzzled so am I, it must be something simple, going back to very basics, if it's rich theres too much fuel, not enough oxygen or the combustion process is faulty, but thats unlikely as there'd be bangs. One thing could be the spark is weak, only occasionally igniting during revolutions, as it is not fully expelled as gas some remains, causing the next ignition sequence to be rich. However even I don't believe that as you'd smell the unburnt fuel or have detonation. So working logically again, we have fuel, we have a spark but do we have compression?? When you rebuilt it did you check and hone the bores, gap the rings etc etc If it ain't compressing it won't burn the fuel correctly. Take the head off check the bores for scoring and the rings are in correctly and gapped, bores are honed if new rings fitted, piston not cracked, good seal at head, and head not cracked. More I think about it this is highly likely to be the problem, how many kicks does it take to start it?

the spark is weaker than i'd like, but it revs up fully, but this isn't under load as it's not insured yet. Really need to get it out for a run. but it does smell of petrol, more so than a two stroke should normally and the spark plug always ends up wet, but that could just be it not getting in the heat range for the plug for self cleaning by burning it off. When rebuilt i took the barrel in to be inspected and honed by a mechanic. i've heard the term "gap the rings" but i could never find what they meant, even when looking in the manual. I'll check the piston isn't cracked and the seal at the head is fine as far as i know but it is under a water cover so i'll check that nothing is getting past. and it's an electric start and starts within a second, maybe 2 when cold. And that's never with the choke as that kills it. thanks

OK Ross ah ha if the plug is wet then the mixture is definitely wrong or possibly the spark too weak. Is it a big fat blue spark or a whitish yellow one?  For now assume piston ok and rings ok as you took barrel to be honed, so provided rings installed right way up if needed, staggered and giving good compression you should be ok for the moment. Some rings (but not all) need to be installed a certain way up usually marked side on top, if not marked the top ring has bevel on top and 2nd ring bevel on bottom if I remember correctly. To check the gap you need to put the ring in the barrel, square it up using the piston pushed against it and measure with feeler gauges. The basic idea is that the gap when the engine is hot is still there, otherwise expansion would cause the ends to meet and ring would crack (simplest way I can put it). The gap on the second ring is larger than the top to prevent the top ring moving with pressure waves, to do all this you need specs. Anyway it ain't burning right, so firstly check the ignition side, coil, leads and plug and make sure that spark is strong. If it is then we need to go back to the carb which is giving too much fuel (or not enough air). Now most carbs are simple, putting it in basics when idling it is controlled by a pilot jet after about 1/8th throttle by a combination of things in the main jet. This is where I;m getting a bit confused by your description, originally your problem was 'it will just about idle' this can only be because it ain't getting enough fuel or air. The wet plugs after revving are a different problem. I think you need to put back the original pilot jet which is larger, check it is not blocked by blowing air through and put all settings back to basic. Let us get it idling correctly before going on to setting up the main jet and needle, get the engine running and warm. Check the throttle cable has free play, turn the idle screw to get a fast tickover. Then turn the mixture screw a tiny bit at a time until engine runs smoothly, pausing between adjustments. With normal right hand thread clockwise moves screw in restricting fuel flow and leaning the mixture and vica versa. If you can't get mixture right then it needs to go up or down a jet size. This is where colourtune is handy for telling you if mixture too rich or lean, too rich smaller jet too lean bigger. Let me know how you do, once engine is idling smoothly you can bring the idle speed down.

ok thanks, i'll go through that list to see if i get anywhere. the spark is yellowish. not how i want it so i'll order a new coil as it's had a new spark plug, lead, all connections cleaned with a file (ground etc) and i've metered out all the ignition components and they've all read within spec, including the coil but i'll put a new one in anyway. Are you thinking that once it sparks better that the idle and mixture screw will have an effect? and thankyou for all your help.

It will definitely help but I still think the problem lies with the jet, do you have a multimeter and know the resistance in the coil, I'd check that before buying a new one. At the same time check spark lead resistance and double check the plug is the right one.

i metered out the pickup coil and the ignition coil and both were within range but the coil was close to being out, the coils are only about £20 so will just get one of those for peace of mind. im going to order a new standard pilot jet so i know it's the correct size and hasn't been played about with by people shoving wires through it etc. i'll report back when ive got the new parts. thanks

Get a new plug too if you can afford it Ross, new ones have been known to be faulty, won't come in wrong.

Doh! Ive finally gone back and read your early comments, which I should have done earlier instead of glancing. Your very first comment ' Adjusted the idle with the throttle cable', oh no, the cable must have play, if it doesn't fuel is possibly coming through the main jet to allow it to idle. This means fuel starvation on the pilot jet, either too small or blocked, it isn't as you say running rich it's starved of fuel when idling, I must read things correctly, my fault. So lets start again with the standard jet, mixture screw halfway and on fast idle.

i have since adjusted the cable to have play, that was just a little test to see if it would idle higher and if that would have any effect on the mixture screw

Log in or register to post comments